[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Another X Question

On Wed, 31 May 2000, Charles Baker <Charles-Baker@utc.edu> wrote:

> Okay, I installed potato on my old Dell XPi 133ST laptop.
> Everything seems to be fine now, except the mouse in X.  In the /dev
> directory /dev/mouse is linked to gpmdata.  I assume this was done
> by the gpm install.  With this setting the builtin optical trackball
> sorta' works on the console.  However, the cursor never moves in X.
> So, I plugged in an external Intellimouse, when I try to move it in
> X the cursor jumps to either the bottom or top of the screen and
> stays there.
>  In my XF86Config I have the IMPS/2 protocol specified and have
> tried /dev/mouse /dev/psaux and /dev/ttyS0 as the devices.  I know
> that /dev/psaux isn't linked to anything.  This XF86Config file
> originally came from someone's website with the same laptop and it
> worked okay under slink, except I could only get 640x480 @256
> colors.  I don't mind the color depth much if I could get 800x600,
> or is that just a wild fantasy?

I suppose your mouse is working (what means "sorta' works" ?) on the
console.  The problem you are experiencing under X is probably due to
the fact that the repeater protocol of gpm and the X mouse config
differ.  To start with, run
and see the line
	Repeat_Type: ...
This is the protocol the mouse appear to be when read from
`/dev/gpmdata'.  With your X setting, you must declare
	Repeat_Type: imps2
If you prefer, you can also set
	Repeat_Type: raw
and put your real mouse protocol in the XF86Config.

Hope it helps,

Reply to: