[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Xircom Realport 10/100 CB not functioning

> On Fri, Mar 24, 2000 at 10:22:58AM -0700, paul@mainland.ab.ca wrote:
> > 
> > Looking through the archives, it seems people have been having success
> > using this card, I, however, have not. 
> > 
> > During the intial Debian base install, if I configure PCMCIA support, it
> > intializes fine, and finds the Xircom card no problem and configures the
> > tulip_cb module. 
[ ... ]
> > eth0: Transmit timed out, status 686980c7, CSR12 000000c2, resetting... 
> > 
> > This continues until I bring down eth0. 
> I had lots of problems like this. The problem is the serial module installed
> by setserial. Either remove setserial, or rmmod serial.o, and it should
> be happier.
> Tim

The module from setserial is toasting the ethernet?  And setserial is being
involved during Debian install?   Double ick.

Although I admit freely to toasting setserial out of hand, since it seems a 
bad idea to "memorize serial port status" on a machine that (a) has changing
serial connections based on whether a card is in, and (b) has changing serial
connections when I'm at different sites...

My advice: 
1) purge setserial.  I'm not sure I believe it's at the heart of what's
   happening to you, but it has been multiple flavors of a pain in the toot 
   for laptoppers.  
2) If the Xircom continues to be trouble, buy a Linksys PCMLM56.  That's the
   10/100 with a built-on extension where the modem and ether ports are - the
   extension has status lights on top - and as an extra bennie, you get your
   other slot back (as long as you put it in the top bay)

* Heather * star@starshine.org *

Reply to: