[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: configuring mouse in X11

> >  I am trying to install debian-linux on a thinkpad 701C.                 
> >  I do have problems in mouse-setup while using XF86Setup.
> >  I tried all possible PS/2-protocols, but none worked.
> > 
> >  During startup I get the messages: >>loading modules: PS/2 
> >  auxiliary pointing device detected: driver installed.<<
> >  and >>starting mouse interface server: gpm<<
> > 
> >  The trackpoint-mouse has just 2 buttons, but there does not 
> >  seem to be an option in XF86Setup for 2-button mouse.
> >  I tried "emulate 3 buttons", but none of the protocols worked.
> > 
> >  Has anyone proposals what to do ?
> > 
> Hi,
> Have you configured it for gpm (text-mode)?  If not, run gpmconfig.  If so,
> what protocol worked for gpm?

funny, she just said that it claimed to detect PS/2, and that it said it
is starting gpm (therefore, she can wildly guess, gpm is successful at 
finding it.)

Much more like her port setting is wrong, and/or her instance of X is
allergic to gpm.

She might try it without gpm... depends how much you really need to mouse
in text mode.  Some folks get by quite happily with screen's cut and paste

On my personal box, though, I have to say I enjoy abusing gpm thoroughly, 
and so would try a bit harder.  I believe gpm has a repeater mode which 
is sometimes used with X and other mouse-grabby apps. The idea is, you 
turn on the repeater, then point the grabby ones at a dev on which gpm 
is reannouncing the mouse communications.

The PS/2 mouse port (raw) is usually /dev/psaux. 

Reply to: