[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem with Knoppix 6.2 18-11-2009's 0wn

Hi there,

The HDD install of the latest version of Knoppix wasn't working for me: my scenario was 
a "I want to create the partitions myself and then you'll see I have what's needed to 
install". Besides many other partitions, I created (with gparted) a swap and a free (and 
big enough) reiserfs partition. Yet, 0wn (the installer) kept telling me I didn't have what 
is needed to make an installation. Checking the logs, I found out that there was a "mount" 
failing. After looking at the code, I found out that it was happening (in my case) twice 
in the code. Here's how I've fixed it (sorry for not providing a diff):

at /usr/share/0wn/0wn-partitioning :

1) on check_partition_empty(), change 
- blockdev --setro "$1"
+ blockdev --setrw "$1" 

2) on check_partition_big_enough(), change 
- blockdev --setro "$1"
+ blockdev --setrw "$1" 

I'm confident that this is *not* the right way to fix the problem, but it surely was 
how I worked around the issue and now have a machine with Knoppix being 
installed :-)

PS -> any follow-ups, please include me in CC, since I'm not subscribed to this 
        mailing list

Best regards, and keep up the good work,
Marcos Marado

Reply to: