[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Regression: overwrite option not working

Hi all,

I am still trying out the persistent image feature and run into a regression.

I put Knoppix on a USB stick together with a persistent image and was trying 
it out on several machines. This was working exceptionally bad, because the 
hardware configuration from the very first Knoppix boot was saved in the 
persistent image and was automatically used on all machines afterwards. It 
was not really obvious to me that this behaviour was the default. In my 
opinion this is really a bad choice to not overwrite the settings by default, 
because it makes the system more or less non-portable.

Then I remembered that I have read somewhere about this "overwrite" option. 
Unfortunately, I could not find any description in the documentation. Anyway, 
I tried this option and ... it just did't work.
Everytime I select this option Knoppix just hangs with the following error 
rsync: recv_generator: failed to stat "/UNIONFS/etc/ssh.wh..wh..opq": 
Operation not permitted (1)
Is there any workaround for this problem? I really need this to work.

I tried the same procedure with Knoppix-5.1.1. There is also an error message 
from rsync but at least it does not get stuck in the boot sequence...



PS: Is it spelled "KNOPPIX" or "Knoppix"? Even on http://www.knoppix.org/ I 
see both variants on the same page...

Reply to: