[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: knoppix 4.02 upgrade

 As I stated earlier, I have re-installed knoppix 4.02 and I have desisted from running apt-get upgrade.
 Regarding the keyboard, I changed keyboards and still cannot use it in kde though it is ok with iceWm. Again I can't seem to get this on so I guess I will again just re-install my system.
 thanks for the help.

----- Original Message ----
From: Laszlo <drills@bluebaysupply.com>
To: debian-knoppix@lists.debian.org
Cc: Napoleon Manuel <npmanuel@yahoo.com>
Sent: Sat Jan  7 10:39:10 2006
Subject: Re: knoppix 4.02 upgrade

On Saturday 07 January 2006 04:11 am, Napoleon Manuel wrote:
> Hi Laszlo,
> When I try to start kde, the process is not completed and returns to the
> start menu. I can run iceWM and terminal and thats all.

What do you mean by this?  X startup fails, then you end up at the F-1 root 
shell?  If so, prior to retyping startX, can you start 
syslog, /etc/init.d/sysklogd start  then try startx, and when that fails 
again, check the logs.  If there is any relevant info logged in syslog or kdm 
or XFree86 or other log, mount a floppy, copy the logs to the floppy, then 
when your system is up where you can send out emails, paste the log info in 
the next response.

Also, on an underpowered system (slow cpu, low memory) it can take a loooong 
time for kde to start.  You state it returns to start menu.  Are you sure 
this is happening or are you ending the process yourself because it seems 
like there is nothing happening for minutes?

Have you tried installing and starting gnome?

> I just re-installed knoppix 4.02 and avoided running apt-get upgrade. It is
> ok now but lately I ran into a problem wherein I cannot use the keyboard.
> It locked! Though am able to start kde and run it without my keyboard! Am
> still trying to figure it out.

Have you tried a different keyboard?  Keyboards die.  Is this perhaps a 
localization issue?  If using a keyboard driver/module other than US PC101 or 
similar, have you tried the generic US keyboard choice to rule out a problem 
with the keyboard? Perhaps another localization issue?

Have you tried starting sshd, setting a password, then logging in remotely via 
ssh, to check the remote keyboard?  Do you have another keyboard of same 
make/model to try via ssh?  Tried removing/reloading the keyboard module (if 
that's possible via ssh)?  Is the keyboard USB, then try PS/2, is the 
keyboard PS/2, then try USB?  Is the keyboard USB, problems with other USB 

Have you checked the kernel mailing list to check for issues with the kernel 
in the current knoppix and your particular brand motherboard/keyboard?

Last time I checked, Knoppix was a mix of testing, unstable and a bit of 
experimental.  Have you checked to see (google) if there are issues with the 
kernel in the knoppix version you are using and your keyboard choice? Or with 
kde?  Sometimes an apt-get update, upgrade just prior to finalizing a release 
may introduce issues that just started creeping into unstable or testing.  
Klaus can't test every combo or every setup prior to getting each release 
out. So some incompatibilities crop up from time to time that can't get fixed 
till the next release unless the distro is installed to disk and 
updated/upgraded.  Perhaps an experimental driver/module is being used for 
your keyboard, and you may be able to downgrade from experimental to 
unstable, or unstable to testing for that particular module?

Can't think of anything else right now.


 -- Laszlo

> Best regards.
> Napoleon
> ----- Original Message ----
> From: Laszlo <drills@bluebaysupply.com>
> To: debian-knoppix@lists.debian.org; Napoleon Manuel <npmanuel@yahoo.com>
> Cc: drills@bluebaysupply.com
> Sent: Saturday, January 07, 2006 11:51:20 AM
> Subject: Re: knoppix 4.02 upgrade
> On Thursday 29 December 2005 01:10 am, Napoleon Manuel wrote:
> > I ran apt-get update and apt-get upgrade on my knoppix 4.02 hd
> > installation.
> >
> >  The problem is I can no longer run  kde on my system. Though am able to
> > run iceWM and terminal. Can somebody help me please?
> >
> >  Napoleon
> Did you receive help on this issue?  Didn't see it until now.  What happens
> when you try  to start kde?debian-knoppix@lists.debian.org
> During some upgrades of kde it sometimes takes some hand editing of kdm to
> keep kde working. This was an issue for me a while back while Debian Sarge
> was still Testing, and a major version of kde entered Sarge.
> Don't remember why, but somehow one desktop ended up running kde using gdm
> as the window manager instead of kdm.  Since kdm is a rather large config
> file, you may want to try using gdm temporarily, if that works, until you
> can workdebian-knoppix@lists.debian.org your way through the config file of
> kdm.
> Have you checked the logs for errors in XFree86 or whatever the newest
> versions of X knoppix is now using?  Do you have a kdm directory in
> /var/log? For example in the desktop where I have gdm as the controlling
> config file even though I'm running kde, I don't have a kdm log file, but I
> do have a gdm directory where I can look for error messages.
> Is your sources list correct?
> -- Laszlo
> --
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Taper shank drills, Silver & Deming drills, surface treated high speed
> steel jobbers length drills, http://www.bluebaysupply.com


Reply to: