[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[debian-knoppix] knoppix boot hang, Asus A7V ATA100

I've got one machine that Knoppix has trouble on (it is GREAT on several others!).

I've searched the web & mailing lists, tried multiple knoppix versions, but to no avail.

It has an Asus A7V (Via KT133) motherboard, and one drive (Quantum Fireball /dev/hde) connected to the on-board Promise ATA100 controller.

When I attempt to boot knoppix on the machine, in either of failsafe, knoppix, expert, and turning off all the 'no---' options listed on the help page, the system hangs. Expert mode shows that it detects the drives & IDE controllers, and then hangs just after printing:

	hda ... sectors...
	hdc ... sectors...
	Spurious 8259a interrupt on IRQ 7

(Then Knoppix hangs)

From the Debian installation on the same machine, I'd expect it to print:

	hde ... sectors

and continue on.  LNX-BBC boots fine, but w/o detecting hde at all.

If I disconnect hde, the Knoppix boots just fine. I've tried the boot options that Linux 2.2 required to support the ata100:

	ide2=0x9400,0x9002 ide3=0x8800,0x8402

But to no avail (didn't expect it to work, as Knoppix is 2.4.x...)

Any suggestions on how to get knoppix to boot with my ATA100 controller & drive? Unplugging the drive every time would be a real bummer. ;-)



debian-knoppix mailing list

Reply to: