[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#670241: Updated qmi_wwan backport based on v3.2.19, including new device IDs from v3.5-rc1

Ben Hutchings <ben@decadent.org.uk> writes:
> On Tue, Jul 17, 2012 at 08:01:24PM +0200, Bjørn Mork wrote:
>> Feel free to close this bug with a wontfix if you like.  After all, the
>> qmi_wwan driver will never be very useful in wheezy, given that the
>> modemmanager package is frozen on a version too old to ever gain QMI
>> support.
> How large are the required changes to ModemManager?  


The next version (0.6) will use a completely new D-Bus API making it
incompatible with the current NetworkManager and any other ModemManager
users. Ref http://www.freedesktop.org/wiki/ModemManager06

And the QMI support might even not be ready for 0.6.  It's currently
being developed in a separate branch and not yet fully operational.

> New hardware
> support is a perfectly good reason for a freeze exception, whichever
> package it's in.

Sure, and I appreciate that.  But do note that this driver does not add
support for any new USB device.  All supported modems are composite
devices having at least one serial port supporting PPP.  This means that
the driver isn't critical for basic device support.  It only adds
support for another device function, which most users will see as


Reply to: