[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#661057: hpsa driver does not support multipath on Smart Array 712m with latest firmware

Hi again,

Steven Williamson wrote:

> Update,

Please test the attached patch against a 3.2.y or 3.0.y kernel.

Example instructions:

 0. prerequisites.

	apt-get install git build-essential

 1. get the kernel history if you don't already have it.

	git clone \

 2. fetch point releases.

	cd linux
	git remote add stable \
	git fetch stable

 3. configure, build, and test.

	git checkout stable/linux-3.0.y
	cp /boot/config-$(uname -r) .config; # current configuration
	make localmodconfig; # optional: minimize configuration
	make deb-pkg; # optionally with -j<num> for parallel build
	dpkg -i ../<name of package>.deb; # as root
	... test test test ...

 4. hopefully it reproduces the bug.  So try the patch:

	cd linux
	git cherry-pick -x -s 9bc3711cbb67
	make deb-pkg; # maybe with -j4
	dpkg -i ../<name of package>.deb; # as root

An alternative set of instructions is at [1].

If the patch seems to work, we can try applying it to sid and letting
Greg know so the fix gets included in upstream stable kernels, too.

Hope that helps,

[1] http://kernel-handbook.alioth.debian.org/ch-common-tasks.html#s-common-official
or the corresponding page in the debian-kernel-handbook package

Reply to: