[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#657302: [3.1.8 -> 3.2.1 regression] No more sound

Yann SOUBEYRAND wrote:

> I don't have the same controls in alsamixer with the two kernels. I took
> two pictures showing that. Do you have any idea why?

Yes, the parser has learned to recognize more controls, among other
changes.  See "git log v3.1.8..v3.2.1 --grep=[Rr]ealtek" for details.

The symptoms are similar to


(silent output on ASUS A6Rp).  The regression is probably due to
v3.2-rc1~38^2~69 (ALSA: hda - Remove all ALC861 and ALC861-VD quirks,
2011-08-23).  Unfortunately, since you have an F3JC and F3JA
respectively, the fix applied upstream (3b25eb690e8c, ALSA: hda - Fix
silent output on ASUS A6Rp) will need tweaking before it can help.

Please contact alsa-devel@alsa-project.org, cc-ing Takashi Iwai
<tiwai@suse.de> and either me or this bug log so we can track it.
Be sure to include:

 - steps to reproduce
 - symptoms
 - what versions you've tried, and in particular what the newest
   working and oldest nonworking versions you've tried are
 - links to alsa-info output and other logs
 - a pointer to this bug log for the full story

If you have time for it, please also follow the instructions from
https://bugzilla.kernel.org/show_bug.cgi?id=42588#c18 to get some
pin routing information (instructions for building a patched kernel on
Debian are at [1]).

Thanks much, and good luck,

[1] http://kernel-handbook.alioth.debian.org/ch-common-tasks.html#s-kernel-org-package

Reply to: