[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#649626: iwl3945: Microcode SW error detected. Restarting 0x82000008

found 649626 linux-2.6/2.6.32-40

Agnonchik wrote:

> I REPRODUCED exactly the same error in 2.6.32-5-686-bigmem. That's
> what I did:
> Added stable-proposed-updates to /etc/apt/sources.list
> worked fine, except a couple of dkms modules which need kernel
> headers. I tried to install linux-headers-2.6.32-5-686-bigmem but
> fauiled because the package depends on gcc-4.3 which appeared to be
> not installable on my system. I wonder if gcc-4.4 can be accepted
> instead of 4.3?
> Nevertheless, the kernel is installed. Though nvidia and virtualbox
> drivers are missed, they are not so important for debugging I think.
> I can observe that wi-fi connection is broken with 2 minutes or so
> period. The strange microcode SW error is issued each time.

Drat.  Thanks very much for checking.

> I can debug further if it makes any sense for the community.

A few directions for that:

- What version of the firmware-iwlwifi package do you have installed?
  Is the behavior any different if you update it?

- If you have time for it, please try some kernels halfway between
  from the list at [1] so we can discover which one introduced the

  If a 3.0-rc2 or newer kernel reproduces the problem, a log would
  also be helpful, since the output for microcode errors was improved.

- You said you are only able to reproduce this with network-manager
  and not ifupdown.  Can you reproduce it using iw and iproute by hand,
  like this?

	/etc/init.d/NetworkManager stop
	ip link set wlan0 up
	iw dev wlan0 connect -w <SSID> key d:0:<key>
	dhclient wlan0

  This would help us get help from upstream.


[1] http://snapshot.debian.org/package/linux-2.6/

Reply to: