[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#653179: [rt2x00-users] Fwd: linux-image-3.1.0-1-amd64: Can't switch off WoW option of RT5390 wi-fi card, notebook wakes on wi-fi activity

On Thu, 05 Jan 2012 08:48:32 +0400
pol kh <kh3095@yandex.ru> wrote:

> Well, I tried the following:
> 1. Installed back preinstalled version of Windows 7 and gave my notebook to guarantee service. They returned it in one day, saying that WoW option were enabled. As I wrote earlier WoW can be managed under Win7 (in properties of Ralink card).
> 2. I had flashed cracked version of BIOS with unlocked advanced menus. Then I disable Wake on PME (PCI Power Management Enable wake up events). Well, now my notebook do not wakes (and from power off).
> Maybe installed version of Ralink card is a special modification for HP, or it is capable with some ACPI management?
> Best,
> kh
> 29.12.2011, 00:14, "Ivo Van Doorn" <ivdoorn@gmail.com>:
> > On Wed, Dec 28, 2011 at 12:09 PM, Gertjan van Wingerde
> > <gwingerde@gmail.com> wrote:
> >
> >>  On 12/28/11 08:56, Helmut Schaa wrote:
> >>>  Hi,
> >>>
> >>>  Am Sonntag, 25. Dezember 2011, 09:07:42 schrieb pol kh:
> >>>>  I'd like to be able to manage WoW option on Ralink 5390 on my HP Pavilion
> >>>>  dv6-6030er. WoW is enabled by default in BIOS, which is locked by vendor.
> >>>>  So I can't switch it off. Using ethtool doesn't help, because driver can't
> >>>>  hanlder with WoW. My notebook wakes on wi-fi activity when I'd like it to
> >>>>  be asleep. I had sent a bug report to Debian GNU/Linux maintainers and got
> >>>>  the following answer (below my bug report is attached):
> >>>  this sounds really strange :). Unfortunately nobody is working on WoW support
> >>>  for rt2x00 currently.
> >>>
> >>>>  Ivo, Gertjan, do we have any information yet how WoW for the ralink devices
> >>>  is supposed to work? Since the WoW framework was already merged AFAIK it might
> >>>  be a trivial thing to add ...
> >>  No, I've never seen any information about this.
> >>
> >>  A quick look at the Ralink legacy drivers also reveal that these do not
> >>  contain any code for this, so it will be difficult to add support for
> >>  this in rt2x00.
> >
> > Even the specsheets don't contain any reference about WoW, so I really
> > can't say anything about it either.
> >
> > Ivo

Please do not top-post.

I took a quick glance at suspend code and it seems that rt2800pci is
not disabling radio before suspend. Am I right? Have you tried taking
interface down before suspend?

  -- Kuba

Reply to: