[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#606589: xen-linux-system-2.6.32-5-xen-amd64 doesn't upgrade from xen-linux-system-2.6.26-2-xen-amd64

severity 606589 important
reassign 606589 xen-hypervisor-4.0-amd64
merge 606590 606589

At the core this is the same issue as 606590. I think a single report is
enough to allow this to be fixed in the relevant place, if the kernel
ends up being the place to fix then the bug can be reassigned as

WRT the grub issue: Conflating two bug reports in one submission is not
generally useful and in this case the behaviour of grub is down to the
grub maintainers, the kernel has no control over the grub menu ordering.


On Fri, 2010-12-10 at 15:47 +0800, Thomas Goirand wrote:
> Package: xen-linux-system-2.6.32-5-xen-amd64
> Version: 2.6.32-28
> Severity: serious
> Tags: squeeze
> When upgrading a fully working server running the Lenny version of Xen,
> with xen-linux-system-2.6.26-2-xen-amd64 installed, the xen-hypervisor
> package isn't installed, and xen-linux-system-2.6.32-5-xen-amd64 either.
> I believe the fix should be quite simple with a "Replaces:" dependency
> added or something similar.
> Also, the "normal" behavior in Lenny is that in Grub, the hypervisor is
> booted first, the option to run the Linux kernel without it being later
> on the list. It would be nice to have the same order in Squeeze in order
> to not break things (but that can have a lower priority than fixing the
> above which is really more annoying...).
> Cheers,
> Thomas Goirand (zigo)
> -- System Information:
> Debian Release: squeeze/sid
>   APT prefers testing
>   APT policy: (500, 'testing')
> Architecture: amd64 (x86_64)
> Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
> Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
> Shell: /bin/sh linked to /bin/bash
> Versions of packages xen-linux-system-2.6.32-5-xen-amd64 depends on:
> ii  linux-image-2.6.32-5-xen-amd6 2.6.32-28  Linux 2.6.32 for 64-bit PCs, Xen d
> ii  xen-hypervisor-4.0-amd64 [xen 4.0.1-1    The Xen Hypervisor on AMD64
> xen-linux-system-2.6.32-5-xen-amd64 recommends no packages.
> xen-linux-system-2.6.32-5-xen-amd64 suggests no packages.
> -- no debconf information

Ian Campbell
Current Noise: Ministry - Watch Yourself

There are two kinds of pedestrians... the quick and the dead.
		-- Lord Thomas Rober Dewar

Reply to: