[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#594089: keyboard-configuration: caps lock keycode problem

On 09/02/2010 03:46 PM, Samuel Thibault wrote:

Tom Vier, le Thu 02 Sep 2010 15:11:49 -0400, a écrit :
It says UNICODE mode and the codes for caps lock are:

press: 0x3a 0xe0 0x66
repeat: 0x3a
release: 0xba 0xe0 0x

0xe6 I guess?


I also just discovered the right shift key goes back a page in
iceweasel. Here are the right-shift codes:

showkey -s:
press: 0x36 0xe0 0x6a
repeat: 0x36
release: 0xb6 0xe0 0xea

All this looks like one of the few keyboard glitches that linux-2.6
fixes for some keyboards known to be bogus, while other keyboards do use
these scancodes to report e.g. multimedia keys.  Could you try
showkey -s with the older, working kernel?


Stable (2.6.26) which worked fine gives the same as Testing (2.6.32):
press: 0x3a 0xe0 0x66
repeat: 0x3a
release: 0xba 0xe0 0xe6

...which makes me think it's an xorg problem, but I'm not familiar with how the whole keyboard stack works.

I tried a different usb keyboard (a Dell) under Testing and it works normally with iceweasel:
press: 0x3a
repeat: 0x3a
release: 0x3b

I wonder why the logitech generates so many codes.

Tom Vier <tom@triadsys.com>
Senior Net/Sys Admin
Triad Systems Engineering, Inc.

703-956-1535 office
703-984-9093 cell
703-404-0308 helpdesk

Reply to: