[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#582275: ext3 filesystem corruption on md RAID1 device

On Jun 18, 2010, at 3:12 AM, Buehl, Reiner wrote:

> Hi Jan,
> I tried for a while with alternate hardware and the original controller but the error did never happen again. I think your idea of a bug in e2fsck's handling of multiply claimed blocks is the only explanation: Maybe during a corruption long ago a number of multiply claimed blocks existed and where reduced with each reboot. Is this possible? How can this be fixed?

It could be an e2fsck bug, or it could be a hardware issue.  In my experience, every time
I've tried digging into problems with e2fsck -fy not fixing all problems in a single
pass, it's been a hardware problem.  That being said, multiply claimed blocks is
something that isn't exercised that much, so it's *possible* that it is an e2fsck bug.

I really would need a reproducible test case before I could do anything though.

 -- Ted

Reply to: