[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#582858: initramfs-tools: MODULES=dep fails when / is ubifs

* maximilian attems <max@stro.at> [2010-06-15 18:14]:
> i'm a bit hesitant of adding it to every initramfs out there:
> /lib/modules/2.6.32-5-amd64/kernel/drivers/mtd/ubi/ubi.ko
> could d-i add it to the relevant installation as hook?
> who does need or may want to use ubi?

Yeah, I think this is a fair point.  UBI/UBIFS is a filesystem for MTD
flash devices, so very few devices will need this.  And d-i doesn't
even have support for UBI/UBIFS at the moment.

So how about you remove the line that adds ubi when MODULES=most is
used.  Everything else in my patch should be ok, though, or did you
see any other issues?

Martin Michlmayr

Reply to: