[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#523570: rt2860sta is searching something in /etc

Package: linux-2.6
Severity: grave
Version: 2.6.29-2

I have an ASUS 1000H with the WiFi:
01:00.0 Network controller: RaLink RT2860

When I tried to use this card with kernel 2.6.29, my attempt did not
lead me to success.

I installed the module rt2860sta and tried to apply a few
WiFi-parameters (essid). The module answered me:

[27377.884113] RX DESC f2b46000  size = 2048
[27377.884941] <-- RTMPAllocTxRxRingMemory, Status=0
[27377.888709] --> Error 2 opening /etc/Wireless/RT2860STA/RT2860STA.dat
[27377.888723] 1. Phy Mode = 0
[27377.888730] 2. Phy Mode = 0
[27377.917121] 3. Phy Mode = 0
[27377.939971] MCS Set = 00 00 00 00 00
[27377.941644] <==== RTMPInitialize, Status=0
[27377.941724] 0x1300 = 00073200

Debian does not contain any files/directories with path /etc/Wireless:

nba:[/home/dimka]# apt-file search /etc/Wireless|wc -l

The module does not apply any parameters, example:

nba:[/home/dimka]# iwconfig ra0 essid test
nba:[/home/dimka]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

ra0       RT2860 Wireless  ESSID:""  Nickname:"RT2860STA"
          Mode:Auto  Frequency=2.422 GHz  Access Point: Not-Associated
          Bit Rate:1 Mb/s
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality=50/100  Signal level:0 dBm  Noise level:-97 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I think that If the module needs in firmware, then it must be placed
into /lib/firmware/. I am in some doubt that file RT2860STA.dat is a
config file.

... mpd paused: Accept - Winter Dreams

. ''`.                               Dmitry E. Oboukhov
: :’  :   email: unera@debian.org jabber://UNera@uvw.ru
`. `~’              GPGKey: 1024D / F8E26537 2006-11-21
  `- 1B23 D4F8 8EC0 D902 0555  E438 AB8C 00CF F8E2 6537

Attachment: signature.asc
Description: Digital signature

Reply to: