[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#461924: Using drivers from linuxwireless.org works for me in Lenny.

On Sunday 20 April 2008 at 18:28:39 maximilian attems wrote:
> On Sun, Apr 20, 2008 at 03:41:47PM +0100, Peter Lewis wrote:
> > Just thought I'd report that I had this problem using a fresh install of
> > Lenny on a Samsung Q35 laptop with an intel 3945 wireless NIC.
> >
> > Installing the latest drivers from linuxwireless.org fixed the problem
> > for me using the standard Lenny kernel.
> they are quite outdate use trunk 2.6.25 snapshot.
> wiki.debian.org/DebianKernel

Thanks, have just tried this, and though the bug which disconnects the 
connection periodically is not present, I do get this during scanning:

iwl3945: Microcode SW error detected.  Restarting 0x82000008.
iwl3945: Error Reply type 0x00000005 cmd REPLY_TX (0x1C) seq 0x000B ser 
iwl3945: Error setting new configuration (-5).
iwl3945: Can't stop Rx DMA.

... repeated three or four times. The system temporarily freezes whilst doing 
so. Once the connection is up, it's fine.

This behaviour was not present with the linuxwireless.org latest drivers, 
which worked perfectly with 2.6.24.


Reply to: