[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#440042: linux-image-2.6-amd64: Installed kernel does not detect CD/DVD writer, installer does

Package: linux-image-2.6-amd64
Version: 2.6.21+8
Severity: grave
Justification: renders package unusable

I recently installed Debian Lenny AMD64 from the first installer DVD.
The installation went fine, and the system started OK. But when I
tried to use the CD/DVD writer, I discovered that the kernel didn't
detect it - it was as if there was nothing there. The only SATA or IDE
devices reported are /dev/sda and its partitions (which is the
harddisk). Loading ide-cd didn't help, loading ide-generic printed the

Probing IDE interface ide0...
Probing IDE interface ide1...

but still nothing happens, no device files, no output in dmesg.

When I boot from the installer and start the shell, I see a /dev/hdb
device file and /proc/ide/ide0/hdb/model says "TSSTCorp CDDVDW
SN-S082H" (this file does not exist when I run the installed kernel).

I have tried upgrading to the newest 2.6-amd64 kernel and also tried
building my own kernel, it's the same no matter what.

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (900, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.18-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages linux-image-2.6-amd64 depends on:

ii  linux-image-2.6.21-2-amd64    2.6.21-6   Linux 2.6.21 image on AMD64

linux-image-2.6-amd64 recommends no packages.

-- no debconf information

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: