[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#435547: linux-source-2.6.18: sis190 driver should not assume ISA bridge is SiS965 only

Package: linux-source-2.6.18
Severity: normal
Tags: patch

The sis190 driver uses the ISA bridge to read various values. It
currently assumes that the bridge is Sis965 only, but recent SIS
motherboards use the Sis966 bridge. The following patch (against
linux-source-2.6.18) should address this. The patch is based on a
similiar fix in the sis900 driver.

--- sis190_orig.c	2007-08-01 16:06:17.000000000 +0200
+++ sis190.c	2007-08-01 16:05:58.000000000 +0200
@@ -1591,6 +1591,9 @@
 	isa_bridge = pci_get_device(PCI_VENDOR_ID_SI, 0x0965, NULL);
+   if (!isa_brige)
+	   isa_bridge = pci_get_device(PCI_VENDOR_ID_SI, 0x0966, NULL);
 	if (!isa_bridge) {
 		net_probe(tp, KERN_INFO "%s: Can not find ISA bridge.\n",

-- System Information:
Debian Release: 4.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-4-686

Dr. Neil Muller  email: neil@dip.sun.ac.za 

Division Applied Mathematics, Department of Mathematical Sciences
University of Stellenbosch

It's not that I'm apathetic, it's just that I'm ....... Um ........
OK, it's that I'm apathetic

A Gentleman is somebody who knows how to play the bagpipes ...
  and doesn't.

Reply to: