[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#409244: initramfs doesn't include the udev firmware helper

On Thu, Feb 01, 2007 at 08:56:12AM +0100, Josip Rodin wrote:
> The other day I tried to boot a Sun Fire 280R that works nicely with kernel
> 2.4.30; however, it didn't work, because the qla2xxx driver can't find
> the firmware image, and it fails to load properly, meaning I can't access
> the hard disks in the machine, and... flop. :)
> I worked around this by including the proprietary file downloaded from the
> URL provided in kernel config help, ql2200_fw.bin, using a hook file.
> It was necessary to load qla2xxx *after* init-premount, because it needs
> udev to load in order to access firmware helper.
> But, for udev to actually use the firmware helper, it sounds like this is
> also needed:
> copy_exec /lib/udev/firmware.agent /lib/udev/
> After that, the hook file that installs into /lib/firmware also needed:
> mkdir -p ${DESTDIR}/lib/firmware
> Those two problems are more general; another cp/copy_exec for the actual
> file is probably a matter for another package, with license issues sorting
> and all that.
> Cf. http://lists.debian.org/debian-sparc/2007/01/msg00074.html and
> http://lists.debian.org/debian-sparc/2007/02/msg00002.html

did you try to use firmware-qlogic?
afaik it has the necessary hooks.

best regards


Reply to: