[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: TLS support (Re: linux-2.4 deprecated)

On Fri, Apr 07, 2006 at 10:44:26AM +0200, Matthias Klose wrote:
> - configure gcc with --disable-tls (on which architectures would that
>   be (not) needed?)

amd64, maybe hppa. Anything with supports tla in sarge and don't ship
with 2.4 kernels.

> - build a libstdc++6 with a gcc, configured with --disable-tls and ship
>   two versions? Would that help the upgrade issue?

Yes, you have to follow the /lib/tls vs. /lib scheme.

> - provide TLS support for 2.4 kernels and an upgrade path?

This is not a solution.


Beam me up, Scotty, there's no intelligent life down here!

Attachment: signature.asc
Description: Digital signature

Reply to: