[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#357224: Kernel panic after udev update

I upgraded to initramfs-tools version 0.56 and made this test:
1. dpkg -i udev_0.087-1_i386.deb
2. reboot (system was bootable)
3. dpkg -i udev_0.087-2_i386.deb
4. reboot (system was bootable)
5. dpkg -i initramfs-tools_0.53c_all.deb
6. reboot (Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,6))

My problem was that after update from udev_0.087-1_i386.deb to udev_0.087-2_i386.deb system was in unbootable state. I was able to solve the problem manually by reinstalling (big gun but works) udev, linux-image and initramfs-tools. I think that my problem was solved between initramfs-tools_0.53c_all.deb and initramfs-tools_0.56_all.deb.

Thanks for your time.
Nice day,

maximilian attems wrote:
[ keep the bugreport on the cc ]

On Thu, 16 Mar 2006, Tonda Mí?ek wrote:

I use lilo (version 22.6.1-7+b1).

that was the reason of your trouble.

I have busybox version 1.01-4.
When the problem occured I has initramfs-tools version 0.53c (today I upgraded to version 0.55b).

can you confirm that it worked and that your system was bootable
after the upgrade.

also please post an ls -l /boot, so we can see that your initrd.img
really got regenerated.

Note that I use cs_CZ locale.

that's fine.
please send the output ls -lrt /boot

celkem 15384
-rw-r--r-- 1 root root 4609111 2006-03-15 22:52 initrd.img-2.6.15-1-k7
-rw------- 1 root root   23040 2006-03-15 22:52 map

that seems to be the initrd.img generated with initramfs-tools 0.53c
did you catch that before your upgrade?

what is saying:
update-initramfs -u -k 2.6.15-1-k7

Reply to: