[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#357236: linux-image-2.6.16-rc5-686: no sound on Lifebook P2120

On Thu, Mar 16, 2006 at 04:23:05AM -0600, Adam C Powell IV wrote:
> The last time sound worked on my Fujitsu Lifebook P2120 was with 2.6.3
> (or maybe 2.6.5, but not with 2.6.8 or anything since).  An identical
> ALSA setup worked with sarge under 2.6.3 but not 2.6.8.  Tried running
> alsaconf again to no avail.  I can get ALSA working with 2.6.8 on all of
> my other machines, and with 2.6.15 on all that I have tried.
> Esd doesn't work, nor do system beeps, and GNOME volume control says no
> volume control elements are found.
> Now under etch (testing), even 2.6.3 no longer works: sounds played
> through esd simply repeat the first second or so over and over again.  I
> keep upgrading the kernel, hoping that this time it will finally work,
> but it hasn't in that long...
> lsmod shows the following sound modules installed:
> snd_ali5451            20172  1
> snd_ac97_codec         82784  1 snd_ali5451
> snd_ac97_bus            2048  1 snd_ac97_codec
> soundcore               8672  1 snd
> snd_page_alloc          9800  1 snd_pcm
> lspci shows:
> 0000:00:04.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 01)
> What other information would help to diagnose/fix this problem?

please file that specific bug in the alsa bugtracking system.
the alsa dev guys are usually quite responsive.
> Thank you for providing this mechanism for testing and reporting on a
> -rc kernel! I hope we can fix this before 2.6.16 is released.

hmm it's already a bit late in the release cycle for alsa updates,
but it would be great if that report reaches upstream so they can fix



ps there was a mail from alsa upstream posted on debian-devel,
how they like the reports to be usefull for them.
i'm sorry that i can't find at the moment, maybe someone else may help
with a pointer.

Reply to: