[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#357236: linux-image-2.6.16-rc5-686: no sound on Lifebook P2120

Package: linux-image-2.6.16-rc5-686
Version: 2.6.15+2.6.16-rc5-0experimental


The last time sound worked on my Fujitsu Lifebook P2120 was with 2.6.3
(or maybe 2.6.5, but not with 2.6.8 or anything since).  An identical
ALSA setup worked with sarge under 2.6.3 but not 2.6.8.  Tried running
alsaconf again to no avail.  I can get ALSA working with 2.6.8 on all of
my other machines, and with 2.6.15 on all that I have tried.

Esd doesn't work, nor do system beeps, and GNOME volume control says no
volume control elements are found.

Now under etch (testing), even 2.6.3 no longer works: sounds played
through esd simply repeat the first second or so over and over again.  I
keep upgrading the kernel, hoping that this time it will finally work,
but it hasn't in that long...

lsmod shows the following sound modules installed:
snd_ali5451            20172  1
snd_ac97_codec         82784  1 snd_ali5451
snd_ac97_bus            2048  1 snd_ac97_codec
soundcore               8672  1 snd
snd_page_alloc          9800  1 snd_pcm

lspci shows:
0000:00:04.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 01)

What other information would help to diagnose/fix this problem?

Thank you for providing this mechanism for testing and reporting on a
-rc kernel! I hope we can fix this before 2.6.16 is released.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Welcome to the best software in the world today cafe!

Reply to: