[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem with kernel-image-2.6.15-1-amd64-generic, maybe udev related?



Hi!
I've got a Turion 64 ML-37 and today I have made
a "aptitude update && aptitude dist-upgrade". This has yielded
one strange problem.
I think it's kernel related because booting
with an older kernel (2.6.8) does not happen.

Description:
When booting it detects the hardware but after detecting the ethernet
card it shows the first strange message:


then
ALERT! /dev/hda3 does not exist. Dropping to a shell!

BusyBox v1.01 (DFebian 1:1.01-4) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

/bin/sh: can't acces tty; job control turned off
/#udevd-event[3069]: run_program: exec of program '/etc/init.d/hdparm'
failed udevd-event[3094]: run_program: exec of program '/etc/init.d/hdparm'


In the shell I run "exit" and it continues normally (as far as I can see).


I use grub as bootloader (root=/dev/hda3)


Any hint of what's going on?

Maybe the initrd image does not have the ext3 module?
I've tried to unpack the initrd image following this guide
http://sial.org/howto/linux/initrd/
but have not found the initrd-util binary.
How could I check whether the initrd image has the module or not...

Any other hint?

Kind regards
Sebastià.

	
	
		
___________________________________________________________ 
Yahoo! Messenger - NEW crystal clear PC to PC calling worldwide with voicemail http://uk.messenger.yahoo.com



Reply to: