[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sound no longer works with kernel 2.6.12



Am Mittwoch, 21. September 2005 16.56 schrieb Maximilian Attems:
...
> > Yes, but alsaconf can't find the card. Neither can the KDE Infozentrum or
> > any other tool I know, only Knoppix (all versions), which finds it OK.
>
> this is an isa sound card?

I don't know. It's an onboard card (IBM Intellistation Pro). alsaconf can't 
find it under ISA (or at all).

> ...alsa driver are always prefixed with snd-, try:
> modprobe snd-cs4232

root@tbox:/home/theo# modprobe snd-cs4232
FATAL: Error inserting snd_cs4232 
(/lib/modules/2.6.12-1-686/kernel/sound/isa/cs423x/snd-cs4232.ko): No such 
device
FATAL: Error running install command for snd_cs4232

...
> please send dmesg output after aboves modprobe.

root@tbox:/home/theo# dmesg
232 soundcard not found or device busy
CS4232 soundcard not found or device busy
...
CS4232 soundcard not found or device busy
cs4231: can't grab control port 0x210
CS4232 soundcard not found or device busy
...
cs4231: can't grab control port 0x210
CS4232 soundcard not found or device busy
...
CS4232 soundcard not found or device busy
ad1848/cs4248 codec driver Copyright (C) by Hannu Savolainen 1993-1996
pnp: Device 01:01.00 activated.
ad1848: PnP reports 'Crystal Audio' at i/o 0x534, irq 5, dma 1, 0
cs4232: set synthio and synthirq to use the wavefront facilities.
kobject_register failed for cs4232 (-17)
 [<c01c296b>] kobject_register+0x6b/0x80
 [<c0222ff6>] bus_add_driver+0x76/0xe0
 [<c01f854d>] pnp_register_driver+0x2d/0x60
 [<d0ce0684>] init_cs4232+0x104/0x121 [cs4232]
 [<c01358e6>] sys_init_module+0xd6/0x1c0
 [<c01030c5>] syscall_call+0x7/0xb
cs4232: Must set io, irq and dma.
can't register device seq
eth0: TX underrun, threshold adjusted.
CS4232 soundcard not found or device busy


I now find that there is a 
file /lib/modules/2.6.12-1-686/kernel/sound/oss/cs4232.ko
(I must have missed it before.)

I try again:

root@tbox:/home/theo# modprobe cs4232
FATAL: Error inserting cs4232 
(/lib/modules/2.6.12-1-686/kernel/sound/oss/cs4232.ko): No such device

However dmesg now added following lines:

cs4232: set synthio and synthirq to use the wavefront facilities.
kobject_register failed for cs4232 (-17)
 [<c01c296b>] kobject_register+0x6b/0x80
 [<c0222ff6>] bus_add_driver+0x76/0xe0
 [<c01f854d>] pnp_register_driver+0x2d/0x60
 [<d0ebe684>] init_cs4232+0x104/0x121 [cs4232]
 [<c01358e6>] sys_init_module+0xd6/0x1c0
 [<c01030c5>] syscall_call+0x7/0xb
cs4232: Must set io, irq and dma.

How can I do this? Thank you for your help.

Theo Schmidt



Reply to: