[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sound no longer works with kernel 2.6.12



On Wed, Sep 21, 2005 at 03:20:39PM +0200, Theo Schmidt wrote:
> Am Mittwoch, 21. September 2005 11.45 schrieb Horms:
> ...
> > Can you try running the following on the command line?
> >
> > modprobe cs4232
> 
> root@tbox:/home/theo# modprobe cs4232
> FATAL: Error inserting cs4232 
> (/lib/modules/2.6.12-1-686/kernel/sound/oss/cs4232.ko): No such device
> 
> There is indeed no such file at that location. Could I copy the file 
> from /lib/modules/2.4.20-xfs/kernel/drivers/sound even though it is called 
> cs4232.o (not .ko), or will this do something nasty?

no.
 
> Am Mittwoch, 21. September 2005 11.47 schrieb Maximilian Attems:
> ...
> > have you alsa installed? (alsa-base, alsa-utils)
> 
> Yes, but alsaconf can't find the card. Neither can the KDE Infozentrum or any 
> other tool I know, only Knoppix (all versions), which finds it OK.

this is an isa sound card?
 
> Is this card perhaps so old that the cs4232 driver is simply missing from the 
> 2.6.12-1-686 kernel?

no alsa driver are always prefixed with snd-, try:
modprobe snd-cs4232
 
> Could I simply replace the file called vmlinuz-2.6.12-1-686 (1.2MB) with a 
> similar file found in Knoppix 4.0 and all will be well, or will everything 
> crash?

no.
kernel and it's modules needs to be compiled with exactly the same gcc
and be of the same version i doubt that it is the case.


please send dmesg output after aboves modprobe.

--
maks



Reply to: