[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#328740: linux-source-2.6.12: xfs filesystem corruption

Package: linux-source-2.6.12
Version: 2.6.12-6
Severity: normal


I'm not sure the kernel is responsible of this problem, this can be lvm as well.

I've 2.6.12 with lvm over a software raid1.
All the filesystems are xfs.
The architecture is X86_64 on an athlon 64 3500+. The system has been created
using this architecture.

While leaving gnome, I remarked that the home filesystem was not present
anymore, I had the followwing message in teh syslog:
Sep 16 18:28:12 tangerine kernel: Filesystem "dm-6": xfs_iflush: detected
corrupt incore inode 1026326, total extents = 1, nblocks = 0, ptr
Sep 16 18:28:12 tangerine kernel: xfs_force_shutdown(dm-6,0x8) called from line
3311 of file fs/xfs/xfs_inode.c.  Return address = 0xffffffff88118d08
Sep 16 18:28:12 tangerine kernel: Filesystem "dm-6": Corruption of in-memory
data detected.  Shutting down filesystem: dm-6
Sep 16 18:28:12 tangerine kernel: Please umount the filesystem, and rectify the

The raid was still running and clean.

I tried xfs_check on the logical volume and the system told me that there was
valuable information on the journal and to do a xfs_repair -L to drop the
jornal. What I did, because it was impossible to mount it.

I got an inode in the lost+found directory, everything else was fine but the
balsa settings directory .balsa.

The system didnt have any crash but a couple of hours before, a program
compilation failed because I ran out of space on an other logical volume. I've
then added dynamically some space on this logical volume and expanded the
matching filesystem. 

I ran memtest86 for 10 hours to be sure (if it is possible to be sure) of the
memory integrity.

The fact I exhausted ne file system "might" have triggered the problem: I
already have this kind of problem in the past.



-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (900, 'unstable')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-k8-9
Locale: LANG=fr_FR@euro, LC_CTYPE=fr_FR@euro (charmap=ISO-8859-15)

Versions of packages linux-source-2.6.12 depends on:
ii  binutils             2.16.1cvs20050902-1 The GNU assembler, linker and bina
ii  bzip2                1.0.2-8.1           high-quality block-sorting file co
ii  coreutils [fileutils 5.2.1-2.1           The GNU core utilities

Versions of packages linux-source-2.6.12 recommends:
ii  gcc                           4:4.0.1-3  The GNU C compiler
ii  libc6-dev [libc-dev]          2.3.5-6    GNU C Library: Development Librari
ii  make                          3.80-11    The GNU version of the "make" util

-- no debconf information

Reply to: