[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.6.12 upload

On Sat, 16 Jul 2005 16:55:42 +0300, Horms wrote:

> On Sat, Jul 16, 2005 at 12:39:55PM +0300, Andres Salomon wrote:
>>   - i'm leaning towards using gcc-3.3, as i'm afraid of gcc-4.0
>>     miscompiling things.  however, if any architectures require gcc-4.0,
>>     either let me know, or update svn directly.
> How are you planing to do that.
> I need to do something about the fact that users go and
> grab kernel-source-2.4.27 and it doesn't compile with the
> default gcc any more. Here are three solutions I have thought.
> 1. Document this somewhere
> 2. Change the makefile to default to gcc-3.3
> 3. Change the makefile to print out a nice error if gcc version >=4.0
> In all cases it seems it would be good to recommend gcc-3.3.

Actually, enough people on IRC have said that gcc-4.0 works for that, that
I'm not convinced gcc-3.3 is necessary.  I'm on the fence, I could go
either way.

Reply to: