[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ACPI hangs kernel boot

On Fri, Jul 02, 2004 at 09:51:46AM -0300, Bruno Diniz wrote:
> Hi,
> I have a Compaq Presario 2100 laptop and since the earlier 2.6.0
> kernel the boot sequence hangs when trying to initialize ACPI. At that
> time, somebody sent me a patch that solved the problem. Since then,
> I've been checking whether the newest kernel-image-xxx package has
> added this patch or something else that solved the problem. So far, it
> seems nothing has been done.
> The problem is with the APIC timer, and the patch I'm sending attached
> disables APIC timer while initializing ACPI and re-enables again after
> ACPI initialization finishes. Could you please analyse this patch to
> figure out whether it could be included on the official debian kernel
> releases?

I can confirm this issue. An easy workaround I used is the 'nolapic' flag
on boot when acpi is on. BTW I had the same problem with 2.4.26 and 2.6

Francesco P. Lovergine

Reply to: