[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: compositing not working after upgrade

> On Tuesday 15 February 2011 03:23:51 Tim Folger wrote:
> > Hi,
> > 
> > I just ran one of my weekly upgrades last night (I'm using sid with the
> > 2.6.32-5-686-bigmem kernel). Now compositing no longer works with kde
> > (4.4.5). When I click "resume compositing," I get a message saying
> > "Compositing has been suspended by another application."  glxinfo | grep
> > render says direct rendering is working. But when I run glxgears, I only
> > get text output, without the animated gears.
> > 
> > My middle mouse button also stopped working after the upgrade, i.e., I
> > can't use it to copy and paste; can't open new tabs in any browser. (The
> > mouse works perfectly in my other two computers, both of which still have
> > kde 3.5.10 installed.) I'm using the radeon driver. None of these
> > problems existed before last night's full-upgrade, so the upgrade
> > definitely broke a few things, and I don't know how to fix them.
> > 
> > Thanks for any suggestions...
> > 
> > Tim
> Look at the output of 'glxinfo | grep -i opengl'. Does it say something
> like "OpenGL renderer string: Gallium 0.4"? libgl1-mesa-dri switched over
> to Gallium drivers for many radeon Cards. Maybe that causes your problem
> with compositing.

You're right--it does say "Open renderer string: Gallium 0.4 on AMD RS880." is 
there anything I can do to get compositing working again? And would this also 
explain why the middle click on my mouse no longer works? 

Reply to: