[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: EOL of KDE SC 4.4.2 in qt-kde.debian.net

On Saturday 10 April 2010 16.04:02 Modestas Vainius wrote:
> Hello,
> On šeštadienis 10 Balandis 2010 16:38:38 Michael Schuerig wrote:
> > However, doing the same with -t experimental updates the entire system
> > to experimental, which is presumably not what most people want. Is
> > there a way to only upgrade KDE-related packages from experimental?
> Bump priority of experimental to 101 (/etc/apt/preferences):
> Package: *
> Pin: release a=experimental
> Pin-Priority: 101
> and do a normal dist-upgrade:
> # aptitude dist-upgrade

... which does exactly what Michael wants to avoid.

You'd have to read the apt_preferences manpage, but from memory there is no 
way to use patterns in the Package: line (ideally you could use the kind of 
patterns aptitude uses in search queries, namely "?source-package(^kde)" - 
I'm quite sure this is not possible but you'd have to check.

What I always do (since I use aptitude in any case and carefully check what 
I update) is going through aptitude's package list using the search query I 
mentioned above.

A "aptitude search " | cut | ... | xargs aptitude install -t experimental" 
kind of hack is left as an exercise to the reader and is the best 
possibility I can think of just now.

-- vbi

I once ran a Linux machine with 8M of RAM
and used a floppy disk as a swap device.
        -- Russel Coker, http://etbe.coker.com.au/2007/09/28/swap-space/

Reply to: