[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with KDE4 upgrade

Let me preface this mail by saying I have run kde4 before from 
experimental (sometime in 2008) but that my ~/.kde4 directory was 
removed before I started the upgrade.  I have been running UNSTABLE and 
kde 3.5

I started the updgrade this morning from within a konsole window using 
aptitude in interactive mode.  Seemingly all the packages were updated, 
although it has taken several loops of allowing some packages to be 
removed to satisfy impossible dependences.  The (in)famous kaboom was 
installed, but has never run.

Once the upgrade was supposidely complete, I exited my kde session, 
exited to a root screen (not in x) and stopped kdm.

HOWEVER attempting to restart kdm it failed prompting that "Greeter 
plugin was not configured", so was unable to enter an X session (gdm is 
also installed but not configured to run).

I tried removing it and then re-installing it - no change - still 
prompts for this message

I tried running genkdmconf with selecting the /etc/kde3 old path and 
with selecting no old kde as two separate attempts.  Both times, no 

I then ran dpkg-reconfigure gdm and made it the default display manager.  
When it started, it asked me if I wanted to use kde.desktop as my 
session.  I said yes, but it just hung my machine solid.  I was unable 
to use Ctrl-Alt-Backspace to kill X, and I was unable to Ctrl-Alt-Del to 
reboot.  Only way to shut machine down was to remove power.

I am now writing this e-mail by installing Gnome-Desktop, and then 
running kmail (1.11.2 from KDE 4.2.2).  All my old mails are intact, and 
the dates seem correct (although the threading - or rather lack of it - 
setting on one of my local folders does not seem remembered).

I am not sure where to go now.  I would like to get back my kde session.  
I guess the first problem is to understand why kdm is generating this 
error message
Alan Chandler

Reply to: