[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [kde4-backports] mount scripts ~/.kde4/Autostart

Lisandro Damián Nicanor Pérez Meyer wrote:
On Monday 01 December 2008 20:35:27 Grammostola Rosea wrote:
Grammostola Rosea wrote:
I got this when I run it in terminal

$ /home/d/.kde4/Autostart/backup_file.sh
Error: device /dev/sda1 does not exist

Then your device it is not in /dev/sda1 :-)

ls /dev to try to see where it is.

Anyway, it's a problem in your script.

Regards, Lisandro.

Strange, it always worked ok, same script :/

There is no /dev/sda1 cause it's not mounted....
any suggestions?

$ ls /dev
agpgart hda2 loop2 ppp ram7 tty0 tty24 tty4 tty55 urandom vcs4 audio hda3 loop3 psaux ram8 tty1 tty25 tty40 tty56 usbdev1.1_ep00 vcs5 bus hda4 loop4 ptmx ram9 tty10 tty26 tty41 tty57 usbdev1.1_ep81 vcs6 cdrom hda5 loop5 pts random tty11 tty27 tty42 tty58 usbdev1.4_ep00 vcs7 console hda6 loop6 ram0 root tty12 tty28 tty43 tty59 usbdev1.4_ep81 vcsa core hda7 loop7 ram1 rtc tty13 tty29 tty44 tty6 usbdev2.1_ep00 vcsa1 cpu_dma_latency hda8 MAKEDEV ram10 rtc0 tty14 tty3 tty45 tty60 usbdev2.1_ep81 vcsa2 disk hdc mem ram11 sequencer tty15 tty30 tty46 tty61 usbdev3.1_ep00 vcsa3 dmmidi hidraw0 midi ram12 sequencer2 tty16 tty31 tty47 tty62 usbdev3.1_ep81 vcsa4 dri hpet mixer ram13 shm tty17 tty32 tty48 tty63 usbdev4.1_ep00 vcsa5 dsp initctl net ram14 snapshot tty18 tty33 tty49 tty7 usbdev4.1_ep81 vcsa6 dvd input network_latency ram15 snd tty19 tty34 tty5 tty8 usbdev5.1_ep00 vcsa7 fd kmem network_throughput ram2 sndstat tty2 tty35 tty50 tty9 usbdev5.1_ep81 watchdog full kmsg null ram3 stderr tty20 tty36 tty51 ttyS0 vcs xconsole fuse log nvidia0 ram4 stdin tty21 tty37 tty52 ttyS1 vcs1 zero hda loop0 nvidiactl ram5 stdout tty22 tty38 tty53 ttyS2 vcs2 hda1 loop1 port ram6 tty tty23 tty39 tty54 ttyS3 vcs3

$ mount
/dev/hda1 on / type ext3 (rw,noatime,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
/dev/hda2 on /home type ext3 (rw,noatime)
none on /tmp type tmpfs (rw)

Reply to: