[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Anyone get KSayIt working?

I wanted to play with this.  So far, I'm not having much luck.

I've installed festival and gstreamer-0.8-jack, and I've tried to use KTTSMgr 
to configure for this pair.

On the "configure speaker" tab, I can set it up to use Festival, but the Test 
button doesn't produce any noise, and OK is always grayed out, so I have to 
cancel or close the window.

On the Audio tab, I can set it up to use GStreamer, but I have nothing in the 
"sink" combo box.  The docs say "If you have no sinks, go look at this other 
page that doesn't say anything about sinks."

"If GStreamer is selected for audio output, choose the GStreamer audio sink 
method here. If no sinks are listed, you need to install at least one. See 
the section called “Requirements”."

So, I go to said page, search for "sink" and get no hits.  I get a link to 
GStreamer's home page, but that doesn't offer any kind of immediate 
explanation what a "sink" is either.

OK, I threw in these packages:

ii  gstreamer0.8-a 0.8.8-3        ALSA plugin for GStreamer
ii  gstreamer0.8-d 0.8.9-2        GStreamer documentation
ii  gstreamer0.8-f 0.8.8-3        Festival speech synthesis plugin for GStream
ii  gstreamer0.8-j 0.8.8-3        JACK plugin for GStreamer
ii  gstreamer0.8-x 0.8.8-3        X videosink plugin for GStreamer
ii  libgstreamer-p 0.8.8-3        Various GStreamer libraries and library plug
ii  libgstreamer0. 0.6.4-1.1      Core GStreamer libraries, plugins, and utili
ii  libgstreamer0. 0.8.9-2        Core GStreamer libraries, plugins, and utili

and these:

ii  festival       1.4.3-16       general multi-lingual speech synthesis syste
ii  festlex-cmu    1.4.0-6        CMU dictionary for Festival
ii  festlex-poslex 1.4.0-5        Part of speech lexicons and ngram from Engli
ii  festvox-ellpc1 1.4.0-3        Castilian Spanish male speaker for Festival
ii  festvox-kallpc 1.4.0-5        American English male speaker for festival,

I went back to the audio config page and the combo box for "Sinks" was full of

"              "
"jacksink      "

The first item on the list is a blank string.

I'm running JACK and ALSA.  I don't and can't use aRts.  I'm not seeing any 
festival/gstreamer stuff showing up in QJackCtl, and I don't hear any noise.  
No surprise.

Anyway, I'm about tired of throwing random things at this problem.  If someone 
has already gotten it working, some direction would be helpful.  Otherwise I 
will probably just uninstall all this stuff and forget I tried to play with 

Michael McIntyre  ----   Silvan <dmmcintyr@users.sourceforge.net>
Linux fanatic, and certified Geek;  registered Linux user #243621

Reply to: