[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: media:/ in 3.4-pre broken?

On Tuesday 22 March 2005 17:30, Joerg Platte wrote:
> Am Montag, 21. März 2005 14:54 schrieb Joerg Platte:
> > I have exactly the same problem on one of my computers. I can mount
> > devices using pmount and KDE mounts removable devices, too. But the
> > IO-slave does not detect this and dies. The same setup (as far I can
> > remember) works without any problems on my notebook, but I can't
> > reproduce it on my other computer. Has anybody solved this issue?
> After removing the symlink "/etc/mtab -> /proc/mounts" kio_media does not
> crash any longer. The ioslave seems to have a problem with parsing the
> contents of /proc/mounts.

Well /etc/mtab was no symlink for me initially, therefore I started fiddling 
around with it but it didn't really change anything. When I remove it, I get 
the error message that /dev/sda1 can't be found in /etc/fstab or /etc/mtab 
which is true, because it is not in /etc/fstab and I just deleted /etc/mtab. 
When I make /etc/mtab a symlink to /proc/mounts (isn't there something 
under /sys nowadays?) I get the old errors, though the format is slightly 
different to the old mtab. Well anyway, mounting stuff and seeing it under 
KDE still doesn't work for me. 

BTW, as I'm using the Kubuntu packages, I reported it as Kubuntu bug 8039

Have fun,

        :: Marcus Thiesen :: marcus@thiesen.org :: www.thiesen.org ::        
           :: ICQ#108989768 :: 0x754675F2 :: thiesen@jabber.org ::        

Do something every day that you don't want to do; this is the golden rule for 
acquiring the habit of doing your duty without pain
                                                                   Mark Twain

Reply to: