[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: relocation error: /usr/lib/libkdefx.so.4: undefined symbol: _ZN6QStyle6polishEP12QApplication

* Sergio Gorelyshev [Fri, 25 Feb 2005 17:20:38 +0200]:
> Hi all. I'm using debian testing now.
> I tried to run kcachegrind. And {subject} error appeared. Then I tried
> to reinstall kdelibs4 and kdebase-bin but error did not disappear.
> Then I tried to build kdelibs from sources. Results are below:

  What version of libqt3c102-mt do you have installed? Please execute
  the following commands:

  $ dpkg -l libqt3c102-mt
  ii  libqt3c102-mt  3.3.3-8        Qt GUI Library (Threaded runtime version), V

  $ md5sum /usr/lib/libqt-mt.so.3
  445db57d6e7f6b256ce54f9561c66fda  /usr/lib/libqt-mt.so.3

  $ objdump -T /usr/lib/libqt-mt.so.3 | grep _ZN6QStyle6polishEP12QApplication
  00291ee0 g    DF .text	00000005  Base        _ZN6QStyle6polishEP12QApplication

  (As Josh said, if there is something wrong, it is in Qt, not in

Adeodato Simó
    EM: asp16 [ykwim] alu.ua.es | PK: DA6AE621
He who has not a good memory should never take upon himself the trade of lying.
                -- Michel de Montaigne

Reply to: