[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

relocation error: /usr/lib/libkdefx.so.4: undefined symbol: _ZN6QStyle6polishEP12QApplication

Hi all. I'm using debian testing now.
I tried to run kcachegrind. And {subject} error appeared. Then I tried to reinstall kdelibs4 and kdebase-bin but error did not disappear. Then I tried to build kdelibs from sources. Results are below:
/bin/sh ../libtool --silent --tag=CC --mode=link i386-linux-gcc  -ansi -W -Wall -Wchar-subscripts -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -DNDEBUG -O2   -Wformat-security -Wmissing-format-attribute   -o libkdefakes.la -rpath /usr/lib -version-info 6:0:2 fakes.lo vsnprintf.lo   
../dcop/dcopidl/dcopidl ../../kdecore/ksycoca.h > ksycoca.kidl || ( rm -f ksycoca.kidl ; false )
../dcop/dcopidl/dcopidl: relocation error: ../dcop/dcopidl/dcopidl: undefined symbol: _ZN7QString11shared_nullE
make[4]: *** [ksycoca.kidl] Error 1
make[4]: Leaving directory `/home/savage/kdelibs-3.3.2/obj-i386-linux/kdecore'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/savage/kdelibs-3.3.2/obj-i386-linux/kdecore'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/savage/kdelibs-3.3.2/obj-i386-linux'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/savage/kdelibs-3.3.2/obj-i386-linux'
make: *** [build-arch-stamp] Error 2

How can i fix this problem?
Sergio Gorelyshev

Reply to: