[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

KDE 3.3 logout crashes my system


I recently installed kde 3.3 from sid and have had a couple of strange
problems. I was wondering if anyone else has had similar issues.

Biggest problem.
Every time I logout of kde, my system completely locks up. I have tried
launching KDE from gdm, or from just a console and had the same result.
After confirming that I want to logout, the screen goes blank, but a
mouse pointer is still visible, but unresponsive. The system does not
respond to keyboard input such as ctrl-alt-F1, ctrl-alt-backspace or
ctrl-alt-del. Furthermore, I cannot ssh to the box from another
computer. The system must be rebooted to resolve the situation. 

Occasionally, I can bypass this problem by using ctrl-alt-backspace to
kill X rather than logging out, however, this does not seem to work
every time.

Another problem is that for some reason, this process ruins mozilla
firefox's bookmarks.html file. Often, after reboot firefox no longer has
any of the bookmarks that it once had, but sometimes it will have maybe
1/3 of them intact, with the others missing. This does not occur
every time the system hangs, but in all cases, mozilla was not running
when I tried to logout of the system.

A similar problem seems to manifest in xmms. Sometimes after attempting
to logout from KDE 3.3, xmms seems to have forgotten some or all of its

Usually, when I have problems with sid, I just wait a few days, and a
new package is available fixing the problem. I decided to join this list
as I haven't been able to find reports of this problem or similar
problems when searching the mailing list archives or on google.

My system is an AMD Athlon XP system with 768 MB of ram, using the
2.4.26 kernel built from the source package. My installation of Gentoo
on the same system does not seem to have the same problems, however, it
is using the newer 2.6.7 kernel (I'm not sure it this is a kernel issue,
but I thought it worth mentioning since the entire system locks up).

Curious if these problems are isolated to myself or if others have seen
similar problems.



Reply to: