[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

KDE 3.1.5/3.2 Status Update - 20040219

KDE 3.2 is slowly being uploaded to experimental. It may take some time to show up there due to the many packaging changes, and therefore the NEW status of many packages.

Available in (or incoming to) experimental:
arts 1.2.0-0pre1v1
kdelibs 3.2.0-0pre1v1
kdeadmin 3.2.0-0pre1v1

NEW - waiting on manual editing of the override file (~once per week)
kdebase 3.2.0-0pre1v1
kdegraphics 3.2.0-0pre1v1
taglib 1.0-1 (to unstable - kdemultimedia 3.2 depends on it)

Note that all of these packages are also available from
deb http://people.debian.org/~ccheney/kde-3.2.0/ ./

Now for 3.1.5

Someone pushed hard on s390, building at least kdebase by hand, so it is now caught up. kdegraphics still needs reset to Needs-Build on mipsel. And, it sounds like the jack-audio-connection-kit mess can be pushed through to testing in the not-too-distant future.

There have been some setbacks since the last status update. kdetoys had an rc bug, so a new version was uploaded and still needs to build on 4 archs. And, the upload of xfree86 4.3 to unstable yesterday caused some problems:

xlibs-dev was split into a bunch of packages, and it is now a virtual package. As such, it was packaged as Architecture: all. This, however, made it immediately replace xlibs-dev 4.2.1-16 on all architectures. It depends, though, on the architecture specific -dev libs which are not available until xfree86 builds on each architecture. What this all means is that any package that depends on xlibs-dev - including xfree86 itself - cannot be autobuilt until xfree86 4.3 is built on that architecture. Since xfree86 build-depends on xlibs-dev, it needs to be built by hand. As far as I can tell, it has not yet been built on the following archs:

xfree86 4.3.0-2

* Packages that still need to build:

kdegraphics 3.1.5-1
mipsel	- failed? Jan 13 due to buggy gcc (3.3.3-0pre1)

kdetoys 3.1.5-3 (0 of 10 days old)
arm	- failed due uninstallable xlibs-dev
ia64	- failed due to uninstallable xlibs-dev
m68k	- Needs-Build
mipsel	- Needs-Build

* Packages not at latest version in testing:
Format: package (version in testing) - reason 3.1.5 can't go in

kdepim (only 3 of 10 days old) - waits for libmal (7 of 10 days old)

kdegraphics - waits for libusb (0 of 5 days old)

  - all wait for jack-audio-connection-kit

current version in testing
kdepim - 3.1.4-1
kdebase - 3.1.3-1
kdegames - 3.1.4-1
kdegraphics - 3.1.4-1
kdeaddons - 2.2.2-4


So, the main bottle-necks now are xfree86 4.3 being built and jack-audio-connection-kit moving into testing.


Reply to: