[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: "Could not start kdeinit. Check your installation and try again."

same error here after KDE 3.1.4-woody -> KDE 3.2.0-0woody1 update. Plus: Most 
Fonts are not anti-aliased.

my config:
woody system + XFree 4.2.1-16 (unstable; no backport)

my investigation:
debugging shows: kdeinit: relocation error: /usr/lib/libqt-mt.so.3: undefined 
symbol: FT_Seek_Stream
I think this is because the libqt3-mt 3.2.1-5woody6 backport was compiled 
against a different freetype6 lib (my unstable is 2.1.7-2 whilst woody is 

Downgrading freetype6 isn't possible since the unstable XFree depends on it.

Thus I tried upgrading libqt3-mt 3.2.1-5woody6 -> libqt3c102-mt 3.2.3-2, since 
this one would be compiled against the correct freetypt6 lib. Unfortunately X 
doesn't start at all after that:
libkdefx.so4: undefined symbol: __ti7QPixmap 
Here the problem seems to be that KDE 3.2.0-0woody1 is compiled against 
libqt3-mt 3.2.1 whilst unstable is 3.2.3.

Next option would be to get XFree 4.2.1-15 (can't use 4.1.x on my laptop) from 
www.backports.org and use it together with the freetype6 of woody. 
Unfortunately I was running out of time here.

Reply to: