[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: "Could not start kdeinit. Check your installation and try again."

Am Donnerstag, 5. Februar 2004 05:56 schrieb peter vdm:
> On Thu, 5 Feb 2004 11:28, Josh Metzler wrote:
> > On Wednesday 04 February 2004 04:01 pm, Schulman.Andrew@epamail.epa.gov
> wrote:
> > > Hello.  I have KDE 3.2, under Debian testing/unstable. I wiped clean my
> > > previous installation of KDE 3.1 (apt-get --purge, rm -rf /etc/kde3)
> > > and reinstalled from the .deb's at download.kde.org.
> >
> > You do realize, don't you, that you installed woody backports of KDE 3.2
> > which were built with gcc 2.95, and so are incompatible with your qt and
> > all other c++ packages from testing/unstable.
> >
> > This might be the cause of your problems.
> I still get the 'Could not start kdeinit' and this is on a totally woody
> system with no unstable packages anywhere with gcc 2.95.4
> Any ideas what would be causing this? Also if I try to compile anything the
> configure always bombs saying it can't find qt-mt library which is also
> installed.
> Any help would be good :)
> cheers Peter vdM

This happens for me also. Have woody with kde 3.2 woody packages from the 
official KDE file server. Cant compile a KDE application like Ksensors.

Error message from configure:
checking for Qt... configure: error: Qt (>= Qt 2.2.2) (library qt-mt) not 
found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
make: *** [build-stamp] Error 1
debuild: fatal error at line 456:
dpkg-buildpackage failed!

config.log :
configure:6937: checking for Qt
configure: 7001: /usr/include/qt/qstyle.h
taking that
tried NO
configure:7113: rm -rf SunWS_cache; c++ -o conftest -DNDEBUG -DNO_DEBUG -O2 
-fno-exceptions -fno-check-new -I/usr/include/qt -I/usr/X11R6/include  
-DQT_THREAD_SUPPORT  -D_REENTRANT  -L/usr/share/qt3/lib -L/usr/X11R6/lib   c
onftest.C  -lqt-mt -lpng -lz -lm -ljpeg  -lXext -lX11 -lSM -lICE  -lresolv 
-lpthread 1>&5
/usr/share/qt3/lib/libqt-mt.so: undefined reference to `FT_Seek_Stream'
/usr/share/qt3/lib/libqt-mt.so: undefined reference to `FT_Get_Short'
/usr/share/qt3/lib/libqt-mt.so: undefined reference to `FT_Forget_Frame'
/usr/share/qt3/lib/libqt-mt.so: undefined reference to `FT_Access_Frame'
/usr/share/qt3/lib/libqt-mt.so: undefined reference to `FT_Get_Long'
collect2: ld returned 1 exit status
configure: failed program was:
#include "confdefs.h"
#include <qglobal.h>
#include <qapplication.h>
#include <qevent.h>
#include <qstring.h>
#include <qstyle.h>
#include <qiconview.h>
#if ! (QT_VERSION >= 222)
#error 1

int main() {
    QStringList *t = new QStringList();
    QIconView iv(0);
    QString s;
    s.setLatin1("Elvis is alive", 14);
    return 0;

Can someone help me with this?

Thank you

Reply to: