[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kvim/vimpart on ppc


I'm new to KDE.  I started using it specifically because I want to use kvim
vimpart (on my powerpc running woody with KDE 3.1).  After a fruitless
search for debs for my platform, I attemped to compile kvim.  After reading
through the Makefile, setting things to what I think is appropriate, I run
./configure and I get this error:

   checking for xmkmf... /usr/bin/X11/xmkmf
   checking for X... no
   checking if X11 header files can be found... no
   checking --enable-gui argument... no GUI support
   configure: error: could not find Qt directory

I always get this, even if I explicitly use all the --enables that is
in the documentation and I ran make reconfig too.  Do you have any idea of
the steps are to take to get this to compile?  I set GUI_INC_LOC =
-I/usr/share/qt3 and GUI_LIB_LOC = -L/usr/lib/qt3, and I set

Anyways, I then opted for a different tactic and I made a little more
progress. I
downloaded the Conectiva rpm for vimpart and kvim and turned them into debs
with alien.  Then I installed them using `dpkg -i`. This was successful.
ended up installing them in /usr/lib/kde3/bin, which may be significant to
problem, I don't know.  According to the instructions distributed with
I should then be able to go to:

   Control Center->KDE Components->Component Chooser->Embedded Text Editor 

and select kvim.  No love though :(  So, do I have to move the vimpart
and/or kvim 
binaries somewhere else, or what?  How to get KDE to see that I have vimpart
and kvim?    

Many thanks,

Reply to: