[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: vimpart, kmail

On Thu, May 01, 2003 at 10:40:45PM +0200, Mickael Marchand wrote:
> > Does anyone have a repackaged deb of kmail, kvim and whatever else needs
> > to be modified that will support using the vimpart
> you need kvim >= 6.1.410 (see freenux.org for apt lines woody/sid) I
> haven't yet pkg-ed vimpart because I didn't consider it usable enough
> for now.  I know Ralf did it once, so the debian directory should be
> quite fine for 3.1.1 since i did not add any structural change in it
> since.

Yeah, I did that hoping it would auto-magically work... of course, I
didn't realize that kmail also needed to be rebuilt.  I did get the
vimpart "installed" -- of course with no where to test it, it's hard to
see if what I did worked. :)

> apt-get source kmail apply the patch 
> (http://freenux.org/kde/patchs/kmail-ktexteditor-3.1.diff) and rebuild the 
> pkg for 3.1.1.

Thanks for the pointers... The reason that I was asking is that I'm
having a hard time building the source.  I'm getting the same error
after grabbing the source and trying to let apt build it as well:

$ apt-get source -b kmail
checking for Qt... configure: error: Qt (>= Qt 3.1.0) (library qt-mt)
not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
make: *** [configure-stamp] Error 1
Build command 'cd kdenetwork-3.1.1 && dpkg-buildpackage -b -uc' failed.
E: Child process failed

Then in the config.log the build error I'm getting (linker error):
configure:22273: rm -rf SunWS_cache; g++ -o conftest -Wnon-virtual-dtor
-Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith
-Wmissing-prototypes -Wwrite-strings -ansi -D_XOPEN_SOURCE=500
-D_BSD_SOURCE -Wcast-align -Wconversion -DNDEBUG -DNO_DEBUG -O2
-fno-exceptions -fno-check-new -I/usr/include/qt3 -I/usr/X11R6/include
-DQT_THREAD_SUPPORT  -D_REENTRANT  -L/usr/share/qt3/lib -L/usr/X11R6/lib
conftest.cc  -lqt-mt -lpng -lz -lm -ljpeg -ldl  -lXext -lX11 -lSM -lICE
-lpthread 1>&5
/tmp/ccKGFVhw.o(.text+0xb): In function `main':
: undefined reference to `QString::null'
/tmp/ccKGFVhw.o(.text+0x10): In function `main':
: undefined reference to `QStyleFactory::create(QString const &)'
/tmp/ccKGFVhw.o(.text+0x1e): In function `main':
: undefined reference to `QString::makeSharedNull(void)'
collect2: ld returned 1 exit status
configure:22276: $? = 1
configure: failed program was:
#include "confdefs.h"
#include <qglobal.h>
#include <qapplication.h>
#include <qcursor.h>
#include <qstylefactory.h>
#include <private/qucomextra_p.h>
#if ! (QT_VERSION >= 0x030100)
#error 1

int main() {
    QCursor c(Qt::WhatsThisCursor);
    return 0;

Looks to me like a library is missing... (lib qt-mt, per the configure
message, perhaps?).  But I have:

(100) kmail $ dpkg -l |grep qt
ii  libqt2         2.3.2-5        Qt GUI Library (runtime version)
ii  libqt2-mt      2.3.2-12       Qt GUI Library (runtime threaded version)
rc  libqt3         3.1.1+cvs.2002 Qt GUI Library (runtime files)
ii  libqt3-headers 3.1.1-7        Qt3 header files
rc  libqt3-mt      3.1.1+cvs.2002 Qt GUI Library (Threaded runtime version)
ii  libqt3-mt-dev  3.1.1-7        Qt development files (Threaded)
ii  libqt3c102     3.1.1-7        Qt Library
ii  libqt3c102-mt  3.1.1-7        Qt GUI Library (Threaded runtime version)
ii  qt2-dev-tools  2.3.2-12       Qt2 development tools
ii  qt3-dev-tools  3.1.1-7        Qt3 development tools
(0) kmail $

Any ideas where to look?  Maybe I'm missing something obvious?


Reply to: