[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sarge and updates today



Interesting :)

I get this :

platinum:/home/dmp# apt-get -s install libpng3
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be REMOVED:
  kdelibs4-dev kdesdk kspy libarts1-dev libartsc0-dev libpng-dev libqt3-mt-dev
1 packages upgraded, 0 newly installed, 7 to remove and 0  not upgraded.
Remv kdesdk (4:3.1.1-0woody1 Official build of KDE for Debian stable:stable)
Remv kspy (4:3.1.1-0woody1 Official build of KDE for Debian stable:stable)
Remv kdelibs4-dev (4:3.1.1-0woody1 Official build of KDE for Debian 
stable:stable)
Remv libartsc0-dev (1.1.1-0woody1 Official build of KDE for Debian 
stable:stable)
Remv libarts1-dev (1.1.1-0woody1 Official build of KDE for Debian 
stable:stable)
Remv libqt3-mt-dev (3:3.1.2-0woody1 Official build of KDE for Debian 
stable:stable)
Remv libpng-dev (1.2.1-1.1 Debian:testing)
Inst libpng3 (1.2.5-10 Debian:testing)
Conf libpng3 (1.2.5-10 Debian:testing)

Oh dear!
I see no sign on libpng12 yet - possibly the UK debian mirror hasn't got it 
yet.  I'll keep an eye on it and see if it fixes itself :)

David

On Wednesday 26 March 2003 23:57, Josh Metzler wrote:
> On Wednesday, March 26, 2003 05:32 pm, David Pye wrote:
> > Hi all,
> >
> > I'm running Ralf's woody packages from ktown, and Debian Sarge.
> >
> > At today's apt-get upgrade, I've got the following problem:
> >
> > platinum:/home/dmp# apt-get upgrade
> > Reading Package Lists... Done
> > Building Dependency Tree... Done
> > The following packages have been kept back
> >   libpng3
> > 0 packages upgraded, 0 newly installed, 0 to remove and 1  not upgraded.
> >
> > If I do:
> >
> > platinum:/home/dmp# apt-get dist-upgrade
> > Reading Package Lists... Done
> > Building Dependency Tree... Done
> > Calculating Upgrade... Done
> > The following packages will be REMOVED:
> >   kdelibs4-dev kdesdk kspy libarts1-dev libartsc0-dev libpng-dev
> > libqt3-mt-dev 1 packages upgraded, 0 newly installed, 7 to remove and 0
> > not upgraded. Need to get 30.9kB of archives. After unpacking 7848kB will
> > be freed. Do you want to continue? [Y/n]
> >
> > It appears the new libpng3 conflicts with some of the kdelibs etc, or is
> > it perhaps related to libpng-dev not having appeared/been replaced?
> >
> > I know you could perhaps say that's what I deserve being stuck
> > uncomfortably on Sarge, between Woody and Sid KDE3.1 packages, but hey :)
> >
> > Just thought I'd mention it, and see if anyone else is stuck there too!
> >
> > David
>
> I am also running Sarge with Ralf's stable KDE 3.1.  I did the apt-get
> update, apt-get -u upgrade combo, and libpng3 was held back.  My next step,
> though, was to do this:
>
> apt-get -s install libpng3
>
> This indicated that the reason libpng3 was held back was that it depends on
> libpng12, which is a new package.  I went ahead and did
>
> apt-get install libpng3
>
> And got libpng3 and libpng12.  Things seem to work fine still.  I don't
> know about those packages getting removed.  Maybe some KDE 3 stuff from sid
> made it to sarge?
>
> Josh



Reply to: