[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Compiling KDE Apps (new thread)

There have been a number of conflicting suggestions about problems with
compiling KDE apps, and I suspect the various suggestions/thoughts may be
right for different configurations. However, as it now stands, it is not
clear what the problem many people seem to be having, or what the solution
is. Some say "there's a bug", the packagers say "no, there's not".

I have read /usr/share/doc/libqt3-mt/README-Debian.gz, and tried the
various suggestions there, but the problem doesn't seem to be addressed.
However, I am not a coder, and really know nothing about how compiling
programs work, so probably wouldn't know the solution if I read it

I also want to say that this is (for me, in any case) not a big issue; the
KDE debs made available by Ralf are fabulous, work great, and have made a
big difference for anyone wanting to run KDE on a stable machine. If I
can't compile the one or two programs not available through ktown.kde.org,
I don't really care. So, rather than griping, I figure the least I can do
is try to digest some of the information on the list to help sort out what
appears to be a fairly common problem.

Here's what I can gather to date:

First, I am still not sure which QT development packages need to be
installed to compile KDE3 applications. There are two, mutually exclusive
packages - libqt3-mt-dev, and libqt3-dev. They conflict, and installing
either one will remove the other. The description for libqt3-dev says it
is deprecated in favour of libqt3-mt-dev; to quote:

	WARNING: The nonthreaded version of Qt3 is
	considered deprecated and may disappear anytime
	in the future. Please use libqt3-mt instead

 I assume this means:

	Install libqt3-mt-dev instead of libqt3-dev

Second, when I (and several others) install the current 3.1.2 version of
the libqt3-mt-dev package (libqt3-mt-dev_3.1.2-0woody1_i386.deb), it
creates the following symlinks in /usr/share/qt3/lib:

 libqt-mt.so		-->     ../../../lib/libqt-mt.so.3.1.1
 libqt-mt.so.3  		-->     ../../../lib/libqt-mt.so.3.1.1
 libqt-mt.so.3.1		-->     ../../../lib/libqt-mt.so.3.1.1
 libqt.so.3     	        -->     ../../../lib/libqt.so.3.1.1
 libqt.so.3.1   		-->     ../../../lib/libqt.so.3.1.1

These all point to /usr/lib. However, there is no *.so.3.1.1 in /usr/lib;
the file names there are *.so.3.1.2. This would explain why people who
experience the above behaviour cannot compile anything, as configure
cannot find the qt development libraries.

Changing the symlinks to point to  ../../../lib/libqt.so.3.1.2 seems to
work for most people (though it doesn't for me, I expect there is
something else wrong with my system). So the next question is:

Is there a bug in libqt3-mt-dev, in that the symlinks in
/usr/share/qt3/lib point to the wrong place??


Reply to: