[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

noatun unusable

Hash: SHA1


Since KDE2, I try to use noatun. Either all it does is being absolutely slow 
or it only crashes. As one can see, I am using Ralph's packages (on sarge).

hendrik@linux:~$ su
linux:/home/hendrik# apt-get install noatun.*
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  artsbuilder noatun noatun-osd noatun-plugins
The following NEW packages will be installed:
  artsbuilder noatun noatun-osd noatun-plugins
0 packages upgraded, 4 newly installed, 0 to remove and 0  not upgraded.
Need to get 4036kB of archives. After unpacking 12.4MB will be used.
Do you want to continue? [Y/n]
Get:1 http://ktown.kde.org woody/main artsbuilder 4:3.1.0-0woody3 [1212kB]
Get:2 http://ktown.kde.org woody/main noatun 4:3.1.0-0woody3 [2465kB]
Get:3 http://ktown.kde.org woody/main noatun-osd 0.09-0woody1 [31.7kB]
Get:4 http://ktown.kde.org woody/main noatun-plugins 4:3.1.0-2woody4 [327kB]
Fetched 4036kB in 45s (88.7kB/s)
Selecting previously deselected package artsbuilder.
(Reading database ... 88512 files and directories currently installed.)
Unpacking artsbuilder (from .../artsbuilder_4%3a3.1.0-0woody3_i386.deb) ...
Selecting previously deselected package noatun.
Unpacking noatun (from .../noatun_4%3a3.1.0-0woody3_i386.deb) ...
Selecting previously deselected package noatun-osd.
Unpacking noatun-osd (from .../noatun-osd_0.09-0woody1_i386.deb) ...
Selecting previously deselected package noatun-plugins.
Unpacking noatun-plugins (from .../noatun-plugins_4%3a3.1.0-2woody4_i386.deb) 
Setting up artsbuilder (3.1.0-0woody3) ...

Setting up noatun (3.1.0-0woody3) ...

Setting up noatun-osd (0.09-0woody1) ...
Setting up noatun-plugins (3.1.0-2woody4) ...
linux:/home/hendrik# exit
hendrik@linux:~$ noatun
mcop warning: user defined signal handler found for SIG_PIPE, overriding
WARNING: Couldn't instanciate artsobject Noatun::Session. (This is normally 
caused by a broken package or compiling kdemultimedia in a --prefix different 
from arts.  It may also be from two conflicting packages, so uninstall every 
arts/artsd package you have installed and try againe.
ERROR: KUniqueApplication: DCOP communication error!

Anybody else seeing this? Or the other way round: anybody successfully running 

artds is installed and runs.:
ii  arts           1.1.0-1woody2  Analog Realtime Synthesizer (aRts) metapacka
ii  artsbuilder    3.1.0-0woody3  Arts synthesizer designer
ii  libarts1       1.1.0-1woody2  aRts Sound system
ii  libarts1-dev   1.1.0-1woody2  aRts Sound system (development files)
ii  libartsc0      1.1.0-1woody2  aRts Sound system C support library
ii  libartsc0-dev  1.1.0-1woody2  aRts Sound system C support library (develop

675 ?     S      0:36 /usr/bin/artsd -F 10 -S 4096 -s 1 -m artsmessage -l 3 -f

0x41645609 in wait4 () from /lib/libc.so.6
#0  0x41645609 in wait4 () from /lib/libc.so.6
#1  0x416badd0 in __check_rhosts_file () from /lib/libc.so.6
#2  0x412b8eeb in waitpid () from /lib/libpthread.so.0
#3  0x408c748a in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.4
#4  0x412b6a44 in pthread_sighandler () from /lib/libpthread.so.0
#5  0x415ce518 in sigaction () from /lib/libc.so.6
#6  0x4005cccd in Engine::Engine () from /usr/lib/libnoatun.so.0
#7  0x4006472f in Player::Player () from /usr/lib/libnoatun.so.0
#8  0x40068f2f in NoatunApp::NoatunApp () from /usr/lib/libnoatun.so.0
#9  0x4001623f in main () from /usr/lib/kde3/noatun.so
#10 0x415be0bf in __libc_start_main () from /lib/libc.so.6


xmms works but an updated xmmsarts is missing in Ralph's collection (available 
in unstable, though).

MP3 preview in Konqueror is very nice :) but also behaves strange (does not 
play 192kbit files) and the preview playing does not stop when the mouse 
cursor moves to an overlayed window, thus leaving the icon area. Looks like a 
not-connected event/signal/whatever.


- -- 
Mein GPG-Key ist auf meiner Homepage verfügbar: http://www.hendrik-sattler.de
        oder über pgp.net

PingoS - Linux-User helfen Schulen: http://www.pingos.org
Version: GnuPG v1.2.1 (GNU/Linux)


Reply to: