[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Need help with sound in 3.1

On Friday 07 February 2003 10:06 am, cwhmlist@bellsouth.net wrote:
> I am having some sound problems with kde 3.1.  When I try to play some
> mp3's using xmms, xmms complains that it couldn't open the audio.  Also,
> when I try to play movies (dvd or divx) using mplayer, I also get no sound.
>  However kaboodle will play the same divx movies find with sound.
> Would someone please let me know what I need to change in kde to allow
> these programs to have sound.

	You don't _necessarily_ need to change anything in KDE; the problem is that 
KDE's sound server, arts, is hogging /dev/dsp. Solution 1: for XMMS, use the 
xmms-arts plugin available at http://www.xmms.org/plugins_output.html; to 
enable it, go to Preferences -> Audio I/O Plugins and for the "Output Plugin" 
select "aRts Driver" once you have installed it. For mplayer, in 
~/.mplayer/config, write '-ao arts'. Note that I think you may need to 
specifically mplayer for arts support, but it's been a while since I've 
compiled mplayer.
	Solution 2: if that sounds like too much work, go to Control Panel -> Sound 
-> Sound System and change the value for "Autosuspend if idle for:" value to 
something smaller, like 10 seconds. Note that the problem with this solution 
is that any KDE sound event will be stalled until after XMMS or mplayer 
quits. So if you're listening to some music but have set up KMail to beep 
whenever you have new mail, you won't get any notification until you close 
XMMS. In my opinion it's better to make XMMS and mplayer play nice with arts, 
rather than the other way around.

Oh what a tangled web they weave who try a new word to conceive!

Reply to: