[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GCC 3.2 now becoming default compiler for Sid!!!

Hash: SHA1

On Donnerstag, 9. Januar 2003 09:46, Karolina Lindqvist wrote:
> torsdagen den 9 januari 2003 00.38 skrev Doug Holland:
> > Just ran dselect, so just to warn people, the new libfam0c102 conflicts
> > with the Karolina KDE3 packages.  I'm holding off on updating until more
> > of the pieces are in place.
> Will this mean that it will be impossible to run packages compiled with the
> old gcc compiler after a while, since a new package might require, for
> example, libfam0c102, where an old package require libfam0 and they are not
> compatible?
> I want to keep backward compatibility, at least for a while. So I have to
> figure out a way out of this. Maybe statically linking libfam, is a
> solution, or to make a special libfam that has a library that ends up
> somewhere else, or has a different .so-name.
> I will be interesting to see how many libraries there are that will give
> this problem.

Have fun. I'd wait until next week when (hopefully) XFree and Qt are migrated. 
Then recompile your stuff. At least I'll do that. And maybe until then KDE 
3.1 is already in sid :-)

> Karolina

- -- 
We're not a company, we just produce better code at less costs.
- --------------------------------------------------------------------
Ralf Nolden

The K Desktop Environment       The KDevelop Project
http://www.kde.org              http://www.kdevelop.org
Version: GnuPG v1.2.1 (GNU/Linux)


Reply to: